Microsoft Excel 2007

Training Workbook

Created by the Office of Information Technologies and Digital Media
Technology Training Services
# Table of Contents

Overview ...................................................................................................................... 5

Section I .......................................................................................................................... 8

  Learning Objectives .................................................................................................... 8

  The Microsoft Excel Interface and Icons ................................................................. 9
    The Active Cell .......................................................................................................... 9

  Entering Data into a Spreadsheet ............................................................................. 10
    Entering Data in a Cell ............................................................................................ 10

  Editing Data ................................................................................................................ 11
    4 Ways to Edit Data .................................................................................................. 11

  Erasing Data .............................................................................................................. 11

  Navigating within a Spreadsheet ............................................................................. 12

  Selecting Data ........................................................................................................... 13

  Resizing a Column or a Row .................................................................................... 15
    Resize a Column using the Mouse ......................................................................... 15
    Resize a Column using Menu Commands .............................................................. 16
    Resizing a Row ....................................................................................................... 17
    Resize a Row using the Mouse .............................................................................. 17
    Resize a Row using Menu Commands .................................................................. 17

  Inserting and Deleting Columns, Rows or Cells ..................................................... 18
    Inserting a Column(s) ............................................................................................ 18
    Inserting a Row ......................................................................................................... 19
    Inserting a Cell ......................................................................................................... 19
    Deleting a Column(s) ............................................................................................... 20
    Deleting a Row(s) .................................................................................................... 20

  Entering Data Using Autofill .................................................................................... 20

  Formatting a Spreadsheet .......................................................................................... 22

  Modifying a Spreadsheet Using Page Setup ........................................................... 23

  Viewing a Sheet in Print Preview .............................................................................. 24
    Accessing Print Preview ......................................................................................... 24

  Printing a Sheet .......................................................................................................... 25

Section II .......................................................................................................................... 26
### Section III

- **Learning Objectives** ........................................................................................................ 26
- **Find and Replace Data** .................................................................................................. 26
  - Find Data ......................................................................................................................... 26
  - Find and Replace Data ................................................................................................. 27
- **Sorting Data in a Worksheet** ....................................................................................... 28
- **Creating and Deleting Comments in a Sheet** .......................................................... 28
  - Insert/Create a comment ............................................................................................. 28
  - Edit a comment .............................................................................................................. 29
  - Delete a comment ......................................................................................................... 29
- **Freezing Panes** ............................................................................................................ 30
  - Freeze a Worksheet Title .......................................................................................... 30
  - Unfreeze a Worksheet Title ....................................................................................... 31
- **Splitting Windows** ...................................................................................................... 31
- **Common Formulas and Functions** ........................................................................... 32
  - Creating an Explicit Formula ..................................................................................... 32
  - Create a Formula using a Function ............................................................................ 33
  - The Most Common Excel Functions ........................................................................... 33
  - Less Common Excel Functions .................................................................................. 34
- **Adding Numeric Values Using the AutoSum Command** ........................................... 35
  - AutoCalculate .............................................................................................................. 35
- **New 3** ........................................................................................................................... 37

### New Sections

- **Learning Objectives** .................................................................................................... 37
- **Goal Seeking** ................................................................................................................ 38
- **The Scenario Manager** ............................................................................................... 39
- **Protecting Cells and Objects** .................................................................................... 41
  - Protecting a Sheet ......................................................................................................... 41
  - Removing Protection from a Sheet .............................................................................. 42
  - Protecting Specific Cells ............................................................................................. 43
- **Named Ranges in a Formula** ....................................................................................... 44
  - Guidelines .................................................................................................................... 44
  - Naming a Range ............................................................................................................ 44
  - Applying Named Ranges in a Formula ......................................................................... 45
Edit/Delete Named Ranges in a Workbook................................................................. 46
The Paste Function Command ........................................................................... 46
Inserting a Function .......................................................................................... 46
Defining, Creating, and Applying Macros to a Spreadsheet............................ 47
   Adding the Developer Tab ........................................................................... 47
   Creating a Macro ......................................................................................... 48
Section IV ........................................................................................................... 49
Excel Specifications & Limits........................................................................... 49
Worksheet and Workbook Specifications and Limits....................................... 49
Calculations Specifications and Limits.............................................................. 50
Charting Specifications and Limits .................................................................. 51
PivotTable and PivotChart Report Specifications and Limits ....................... 51
Shared Workbook Specifications and Limits.................................................... 51
Overview
Microsoft Excel is a spreadsheet program that is part of the Microsoft Office Suite. Microsoft Excel has changed. With Excel 2007 you have access to more visible and accessible efficiency tools. Instead of toolbars being hidden in menus or not displayed, there is a control center that now gives you unparalleled access to everything you need to complete tasks. The user is now met with an exciting new version that groups commands together in a wonderful new design.

Home
This tab gives you access to formatting tools for your document. You have easy access to the clipboard, fonts, alignment tools, number formatting tools, styles, cell editing tools, and other sorting and editing tools.

Insert
This tab allows you to insert tables, illustrations, charts, links, as well as additional text and symbols.
Page Layout

The page layout feature gives you easy access to adjust your page setup (including margins), office themes, Scale to Fit options, Sheet options, and document arrangement.

Formulas

Under your formulas tab, the functions library allows you to insert functions, AutoSum, add date and time, etc., make use of the defined names option, do formula auditing, and perform calculations.

Data

Under the mailings tab, you can effectively manipulate data utilizing options to get external data, connections, sort and filter, data tools, and the outline function.

Review

In the Review section you are able to proof your document, add comments, and create changes (including track changes, share workbooks, and protect sheets and workbooks).
View

Under this tab you can change your workbook views, show or hide items in your document (e.g. the ruler or gridlines), zoom, determine window arrangement, and view macros.

Developer

The developer tab gives you access to codes (macros), controls such as design mode and legacy tools, XML, the option to protect the document, and templates.
Section I

Learning Objectives

- The Microsoft Excel Interface and Icons
- Entering data in a spreadsheet
- Editing data using one of different techniques
- Navigating a spreadsheet using various techniques
- Selecting data using various techniques
- Altering the size of a row or column
- Inserting rows, columns or cells in a spreadsheet
- Entering data into a spreadsheet using the AutoFill command
- Format a spreadsheet
- Modifying a spreadsheet using Page Setup
- Viewing a sheet in Print Preview
- Printing a sheet
- Workbook and Worksheet specifications & Limits
- Calculations Specifications & Limits
The Microsoft Excel Interface and Icons

The MS Excel Workbook is capable of having multiple worksheets. The MS Excel Sheets are capable of holding 1,048,576 rows and 16,384 columns of data.

The intersection of a column and a row is called a Cell. A Cell Reference is the column reference and then the row reference. For example, B28, where B is the column reference and 28 is the row reference.

The Active Cell

When using MS Excel, one of the cells will always have a dark border around it. That particular cell is called the Active Cell. This cell/s will be affected by the commands you initiate.
Entering Data into a Spreadsheet

Entering Data in a Cell

1. Select the cell where you want the information to appear by clicking on it.
2. Type the data.

1. Press Enter on your keyboard when you are finished.

*Note that there are three different types of data that can be entered into a spreadsheet. These are:*  
   1. Labels  
   2. Values  
   3. Formulas

It is extremely important that you use labels in Excel. A label defines the information in the spreadsheet. That is, any information besides phone numbers, numbers, formulas, etc.

Values in MS Excel are any numbers you wish to enter that will be used as part of a calculation. Values consist of any numbers 0-9, any mathematical operators +,-,*, /, = (addition, subtraction, multiplication, equal sign), any currency symbols or parentheses.

A Formula is defined as a mathematical calculation.
Editing Data

4 Ways to Edit Data

1. You can simply click the cell you want to edit and type over the data in the cell.
2. You can also press the F2 key on the keyboard and the cell will go into Edit Mode (look at the picture above).
3. Double clicking a cell will also take you into Edit Mode.
4. If you have a large amount of data in a cell you may want to edit the data in the Formula Bar. Click the cell to be edited and then click in the formula bar. (See picture below).

Erasing Data

To erase data in a cell there are several steps you can take:

1. To clear the content of a cell where the formatting will remain, select the cell/s and press Delete on the keyboard.

HOT COCOA

<table>
<thead>
<tr>
<th></th>
<th>July</th>
<th>August</th>
<th>September</th>
<th>October</th>
<th>November</th>
<th>December</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folgers</td>
<td>2200</td>
<td>7850</td>
<td>2350</td>
<td>2730</td>
<td>2850</td>
<td>2600</td>
</tr>
<tr>
<td>Tastys</td>
<td>1500</td>
<td>2300</td>
<td>2596</td>
<td>2780</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Grace</td>
<td>2250</td>
<td>565</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
2. To undo a clear, click the **undo** icon located on the quick access toolbar at the top of your screen.

3. To clear all the data and formatting in a cell select the cell/s, then click on the **Clear** icon and choose **Clear All** from the drop down menu.

4. To clear the formatting within a cell, but not the data, select the cell/s, click on the **Clear** icon and choose **Clear Formats**. See Below.

   ![Clear Formats](image)

   **Navigating within a Spreadsheet**

   MS Excel holds a large amount of information. The mouse and the scroll bars can be used to navigate the sheet. However, in certain instances, it is more efficient to use other techniques to navigate within a sheet.

<table>
<thead>
<tr>
<th>To move to the Home Cell (A1)</th>
<th><strong>&lt;Ctrl&gt;+&lt;Home&gt;</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>To move to Column A of the current row</td>
<td><strong>&lt;Home&gt;</strong></td>
</tr>
</tbody>
</table>

To go to a specific cell

1. **Use the GoTo Dialog Box** (see Figure 1 below).
   - To access the box use one of the following techniques:
     - Press the `<F5>` key on your keyboard
     - Press `<Ctrl>+<G>` on your keyboard

2. **Use the Name Box**.
   - Click the mouse pointer directly in the **Name Box** (see figure 2 below) and type the cell reference, e.g., B28, then press **Enter**.

To move Right and Left

- To move right, press the **Tab** key on your keyboard
- To move left, press **Shift+Tab**

To move from one worksheet to another

- Press **<Ctrl>+<Page Down>** to go to the next sheet.
- Press **<Ctrl>+<Page Up>** to go to the previous sheet.

To move to the end of the information in the sheet

- Press the `<End>` key once on your keyboard, then press any of the directional arrow keys for the direction in which you want to go.
Selecting Data

In order for MS Excel, or any other application, to perform a specific command, like copy, format or delete, MS Excel needs to know what data should be affected by the command.

For example, on the following spreadsheet, you want to make all the labels bold. Select all the labels, and then click on the bold icon. If you clicked the bold icon without first selecting those cells, they would not be affected and no change will be made.

There are many way to select cells. Depending on your needs, different techniques will be effective. Look at the table below to see the different ways to select data in MS Excel.
<table>
<thead>
<tr>
<th>When selecting</th>
<th>Perform this function</th>
</tr>
</thead>
<tbody>
<tr>
<td>A single cell</td>
<td>Click the cell, or press the arrow keys to move to the cell.</td>
</tr>
<tr>
<td>A range of cells</td>
<td>Click the first cell in the range, and then drag to the last cell, or hold down SHIFT while you press the arrow keys to extend the selection. You can also select the first cell in the range, and then press F8 to extend the selection by using the arrow keys. To stop extending the selection, press F8 again.</td>
</tr>
<tr>
<td>A large range of cells</td>
<td>Click the first cell in the range, and then hold down SHIFT while you click the last cell in the range. You can scroll to make the last cell visible.</td>
</tr>
<tr>
<td>All cells on a worksheet</td>
<td>Click the <strong>Select All</strong> button. To select the entire worksheet, you can also press CTRL+A.</td>
</tr>
<tr>
<td>Nonadjacent cells or cell ranges</td>
<td>Select the first cell or range of cells, and then hold down CTRL while you select the other cells or ranges. You can also select the first cell or range of cells, and then press SHIFT+F8 to add another nonadjacent cell or range to the selection. To stop adding cells or ranges to the selection, press SHIFT+F8 again.</td>
</tr>
<tr>
<td>An entire row or column</td>
<td>Click the row or column heading. If the row or column contains data, CTRL+SHIFT+ARROW key selects the row or column to the last used cell. Pressing CTRL+SHIFT+ARROW key a second time selects the entire row or column.</td>
</tr>
<tr>
<td>Adjacent rows or columns</td>
<td>Drag across the row or column headings. Or select the first row or column; then hold down SHIFT while you select the last row or column.</td>
</tr>
<tr>
<td>Nonadjacent rows or columns</td>
<td>Click the column or row heading of the first row or column in your selection; then hold down CTRL while you click the column or row headings of other rows or columns that you want to add to the selection.</td>
</tr>
</tbody>
</table>
The first or last cell in a row or column
Select a cell in the row or column, and then press CTRL+ARROW key (RIGHT ARROW or LEFT ARROW for rows, UP ARROW or DOWN ARROW for columns).

The first or last cell on a worksheet or in a Microsoft Office Excel table
Press CTRL+HOME to select the first cell on the worksheet or in an Excel list.

Press CTRL+END to select the last cell on the worksheet or in an Excel list that contains data or formatting.

Cells to the last used cell on the worksheet (lower-right corner)
Select the first cell, and then press CTRL+SHIFT+END to extend the selection of cells to the last used cell on the worksheet (lower-right corner).

Cells to the beginning of the worksheet
Select the first cell, and then press CTRL+SHIFT+HOME to extend the selection of cells to the beginning of the worksheet.

More or fewer cells than the active selection
Hold down SHIFT while you click the last cell that you want to include in the new selection. The rectangular range between the active cell and the cell that you click becomes the new selection.

Resizing a Column or a Row

<table>
<thead>
<tr>
<th></th>
<th>July</th>
<th>August</th>
<th>September</th>
<th>October</th>
<th>November</th>
<th>December</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folgers</td>
<td>2200</td>
<td>7850</td>
<td>2850</td>
<td>2600</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tastys</td>
<td>1500</td>
<td>2300</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Grace</td>
<td>2250</td>
<td>565</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The above example displays a common occurrence in MS Excel. Look at the column for the November totals. The user has typed in data that is too large to fit in the column. Look at the column for the July totals. That column is much smaller than the other columns.

Resize a Column using the Mouse

1. Visually locate the column to be resized.
2. Using the mouse, place the pointer to the right of the COLUMN HEADER.
3. In the example below, if the July column is too small, place the pointer to the right of column header “B”.
4. Once the pointer is between two column headers, a double headed arrow with a line going through it will appear.
5. When the special pointer appears, click and drag in the direction that will increase or decrease your column (based on your needs).
6. When you see that special pointer, click and drag in the direction you would like the column to be sized to.

You may also double click on the line between the two column headers. MS Excel will automatically fit the column size to the contents of data in the column. This technique is called AutoFit.
7. To size all the columns at the same time and to the same size, select the entire sheet (<ctrl>+<A>), then double click on the line between any of the column headers.

Resize a Column using Menu Commands

1. Select the column(s) to be resized.
2. Click the Format menu on the home tab, under the cells section and select column width.

3. The following box will appear. In this box, type a value from 0 through 255 to change the width of columns where you have selected cells. This number represents the number of characters that can be displayed in a cell. If the column width is 0, the column is hidden.

4. Click OK.
### Resizing a Row

In the example above, row 7 is not the same size as the other rows. MS Excel can easily resize a row to fit data. **By default, rows in MS Excel are 15.00 in height.** Row size can be changed using the mouse or using the menu commands.

#### Resize a Row using the Mouse

1. Visually locate the row to be resized.
2. Using the mouse, place the pointer to the bottom of the row header.
3. In the example above, where row 7 is too big, place the pointer below row header 7.
4. Once the pointer is between two row headers, a double headed arrow with a line going through it will appear.
5. When the special pointer appears, click and drag in the direction the row is to be sized (you can also double-click on the line between the two row headers to resize it automatically to fit).

#### Resize a Row using Menu Commands

1. Select the column/s to be resized.
2. Click the **Format** menu on the **Home** tab, under the cells section, and select **Row Height**.
3. The following box will appear. **Type a value** from 0 (zero) through 409, which represents the row height in points. Then Click **OK**.

   *Note that if you set the row height to 0, the row will be hidden*

![Row Height dialog box]

4. Click **OK**.
5. To size all the rows at the same time and to the same size, select the entire sheet (<ctrl>+<a>), then double click on the line between any of the row headers.

**Inserting and Deleting Columns, Rows or Cells**

**Inserting**

When performing data entry, some records may accidentally be skipped. Sometimes, it may be necessary to add information. Therefore, learning to add an extra column, row or cell can be very important to the data entry process.

*Note the following*

- When you insert a new row, MS Excel inserts the same number of rows selected **above** the current location.
- When you insert a new column, MS Excel inserts the same number of columns selected **left** of the current location.
- If you need to insert a column or row inside a range of data that contains formulas, MS Excel will include the new area/s in the formula. If the column or row is inserted outside the formula, then you will have to adjust the formula to include the new area/s.

**Inserting a Column(s)**

1. Select the number of columns to be inserted.
2. Right-click on the selection and select insert under the Home tab, then select the column/s
3. Right-Click in the selected column/s and select **Insert** from the menu that appears. If the box below appears, make your selection and click **Ok**.

![Insert dialog box]

**Inserting a Row**

1. Select the number of rows you want to be inserted.
2. Click the Insert menu, then select Rows

   **Or**

3. Right-Click in the selected rows and then select Insert.

**Inserting a Cell**

1. Select the location of where the new cell should be inserted by clicking on it.
2. Click on Insert, and then insert cells. The following box will appear.

   **Or**

3. Right-click on the cell and select **Insert** from the menu that appears. The following box will appear.
4. Make your selection and click **OK**.

![Insert dialog box]
Deleting

After all the data in a worksheet has been entered, deletions may have to be made.

Deleting a Column(s)

1. Select the number of columns to be deleted.
2. Click on the Delete icon. A drop down menu will appear. Select delete sheet columns and the changes will be made immediately.
3. Or select the columns to be deleted, right-click and select delete.

Deleting a Row(s)

1. Select the number of rows to be deleted.
2. Click on the Delete icon. A drop down menu will appear. Select Delete Sheet Rows and the changes will be made immediately.

Entering Data Using AutoFill

MS Excel contains a feature called AutoFill, which copies a logical series of values, labels or formulas. The AutoFill handle can be located at the bottom right corner of the Active Cell(s).

Place the pointer over the small square in the bottom right corner of the Active Cell(s). The pointer will change to a cross hair. Click and Drag in any direction. The data to be entered automatically will pop-up. Then release the mouse button.
Examples

<table>
<thead>
<tr>
<th>If you Enter</th>
<th>The Result will be</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monday</td>
<td>Tuesday, Wednesday, Thursday, etc.</td>
</tr>
<tr>
<td>January</td>
<td>February, March, April, etc.</td>
</tr>
<tr>
<td>1 Qtr</td>
<td>2 Qtr, 3 Qtr, 4 Qtr</td>
</tr>
<tr>
<td>1/2/00</td>
<td>1/3/00, 1/4/00, 1/5/00, etc.</td>
</tr>
</tbody>
</table>

To get numbers in a specific sequential order (1, 2, 3 or 10, 20, 30), you **MUST** set up a two cell pattern for AutoFill to follow.

1. Type the first two numbers in the sequence in two separate cells.
2. Select both cells and then drag to AutoFill.
**Formatting a Spreadsheet**

You can use the formatting toolbar (Microsoft Excel Ribbon) to apply quick and simple formatting changes to the data in your worksheet. If more complex formatting changes need to be made, then use the Format Menu under the cells section of your Home Tab.

1. Remember to select data before attempting to format or changes will not be reflected.
2. Once you have selected the data you can utilize one of the techniques below.

<table>
<thead>
<tr>
<th>To</th>
<th>Perform the following technique</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the font</td>
<td>Click the drop-down arrow on the Font box and select the font of your choice.</td>
</tr>
<tr>
<td>Change the font size</td>
<td>Click the drop-down arrow on the Font Size box and select the font size of your choice.</td>
</tr>
</tbody>
</table>
Modifying a Spreadsheet Using Page Setup

Before printing, view the spreadsheet to make sure it is set up properly. The setup, for example margins or page orientation, may need to be altered. For your page setup options, click on the Page Layout tab on your Excel Ribbon. Under this tab you can do several things, including:

1. Adjust margins
2. Change page orientation
3. Create a Header and Footer
4. Adjust Excel color themes
5. Change Page Size
6. Set/Clear Print area
7. Create page breaks
8. Change the background
9. Set Print Titles
10. Scale to Fit
11. Choose Sheet Options
Viewing a Sheet in Print Preview

Print Preview allows you to see the document the way it will be printed before it actually prints. You are then able to make adjustments before printing your document.

Accessing Print Preview

1. Click on your office button
2. Click on Print and select Print Preview

3. When you are finished in Print Preview either click the Close Print Preview button to go back to the Normal view or click the Print button to print. You can also adjust page setup from this window.
Printing a Sheet

There are two ways to print in Microsoft Excel 2007.

1. Click the Office Button, select Print and then Quick Print. This will send the document directly to your default printer. Selecting Print, instead of Quick Print will open your print dialog box.

   Or

2. Press Ctrl+P on the keyboard. This will open your Print dialog box.
3. Make your selections and click OK to print.
Section II

Learning Objectives

- Find and Replace Data
- Sorting data in a worksheet.
- Creating and Deleting Comments in a Sheet
- Freezing Panes
- Splitting a Window
- Common Formulas and Functions
- Using Mathematical Functions (Sum, Minimum, Maximum, Average)
- Add numeric values using the AutoSum command
- Less Common Excel Functions
- Calculate values using the AutoCalculate box

Find and Replace Data

A search can take place to locate specific text or numbers within a sheet. The data can be reviewed or edited, and automatically replaced once found.

Find Data

1. Click the Edit menu and select Find or press <Ctrl>+<F> on the keyboard.
2. The **Find and Replace** box will appear. Type the data in the **Find What** box.

3. Click **Find Next**. Excel will go the next occurrence of the data being searched for.

**Find and Replace Data**

1. Click on the **Find and Select** icon under the Home tab.
2. Select **Replace** or Press `<Ctrl> + `<H>` on the keyboard.
3. The **Find and Replace** box will appear. Type the data to be searched for in the **Find What** box.

3. In the **Replace With** box, type the characters that you want to replace the characters in the **Find What** box. (To simply delete the characters in the **Find What** box from your document, leave the **Replace With** box blank)

4. Click **Replace All** to replace all occurrences of the data or click Replace to alter each cell one at a time.
5. When finished, click **Close**.
**Sorting Data in a Worksheet**

It may be necessary to change the order of information in a spreadsheet. To sort a spreadsheet means to reorder the text or numbers in ascending or descending order. By default, MS Excel sorts all data in ascending order. Criteria such as Last Name or Social Security Number, is normally used to sort data.

**MS Excel, when sorting data, uses the following guidelines**

- Rows with blank cells are placed at the bottom of the sorted list.
- Hidden rows are not moved.
- Values are sorted before text and before numbers formatted as text.
- Numbers formatted as text are sorted before text alone.
- The sort options are saved from the last sort done until the column labels or the sort is changed in the list.

1. Click on the **Data** tab
2. Select the columns you would like to sort.

3. You can also sort in ascending or descending order by clicking on one of these icons.

Or

4. Select **Sort** in the **Sort & Filter** category. The following box will appear.

**Creating and Deleting Comments in a Sheet**

A comment is a note that explains, identifies or comments on data within a cell. Think of a comment like an electronic "sticky-note".

**Insert/Create a comment**

1. Click in the cell that will contain the comment.
2. Right-click and select Insert comment from the menu that appears.

Or

3. Under the Review tab, click on New Comment.
4. The comment box below will appear

5. Type the comment and then click outside the comment box. A red comment indicator will appear in the upper right corner of the cell.
6. Place your pointer over the indicator; the comment will then pop up.

Edit a comment

1. Right-click on the cell containing the comment to be edited.
2. Select Edit comment from the menu that appears. The comment box will appear.
3. Edit the comment and then click outside the comment box to save the changes.

Delete a comment

1. Click on the cell containing the comment to be deleted.
2. Click the Edit menu, select Clear and then select Comments or Right-click the cell and select Delete Comment.
3. The red comment indicator will be removed from the cell.
Freezing Panes

Freezing a worksheet title is a handy technique for viewing large worksheets that stretch out farther than the window. In MS Excel, freezing the column titles in their place gives the user the flexibility to see additional information.

Freeze a Worksheet Title

1. To lock rows, select the row below where you want the split to appear. Then on your View tab, in the Window section select Freeze Pane.
2. To lock columns, select the column to the right of where you want the split to appear. Then on your View tab, in the Window section, select Freeze Pane.
3. To lock both rows and columns, click the cell below and to the right of where you want the split to appear. Then on your View tab, in the Window section select Freeze Pane. The following menu will appear.
Unfreeze a Worksheet Title

1. Click the cell that was used previously to freeze panes.
2. Click on your View tab.
3. In the Window section, select Unfreeze Pane. The following menu will appear. Select Unfreeze Panes.

Splitting Windows

When working with a large spreadsheet, it may be necessary to view different parts of the sheet at the same time. Splitting the window will allow the user to view two or four screens of data at the same time. The areas of data viewed do not necessarily need to be adjacent to each other.

1. To split panes, point to the split box at the top of the vertical scroll bar or at the right end of the horizontal scroll bar.
2. When the pointer changes to a split pointer or and drag the split box down, or drag it to the left and stop at the position that you want.

3. To remove the split, double-click any part of the split bar that divides the panes.

Common Formulas and Functions

A Formula is sequence of values, cell references, names, functions, or operators in a cell that produce a new value from existing values. A formula always begins with an equal sign (=).

Formulas are dynamic in use because when one of the values change, MS Excel automatically recalculates the values to return a new result. The next few sections will provide information on ways to calculate values in Microsoft Excel 2007.

Creating an Explicit Formula

Using mathematical operators (+, -, *, /), specify exactly what calculation should be performed (See example below).

1. Select the cell that will contain the result of the formula.
2. Type an equal sign and then type the formula to be calculated, remembering to include the cell references.
3. Press the Enter key.

```
1  2  3  4  5  6  7  8  9  10
1 | 45 |
2 | 2456 | C4
3 | 2365 |
4 | 2008 |
5 | 20025 |
6 | 513 |
3 | 532 |
```

```
=C4+C6+C9+C8+C7
```

```
1  2  3  4  5  6  7  8  9  10
1 | Total |
2 | =C4*C6*C7*C9/C4 |
3 | Enter |
4 | Total |
5 | 2.14E+08 |
```
4. The result will appear in the cell and the formula can be seen in the Formula Bar.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>45</td>
<td>2456</td>
<td>2365</td>
<td>2008</td>
<td>=C4<em>C6</em>C7-C9/C4</td>
<td></td>
</tr>
</tbody>
</table>

The result will appear in the cell and the formula can be seen in the Formula Bar.

**Functions**

Many of the most popular calculation performed in MS Excel are done using functions. Functions are predefined formulas that perform calculations by using specific values, called arguments, in a particular order, called the syntax.

In the sample below, the function that MS Excel is performing in Sum (adding values to get a total). Just as with explicit formulas, MS Excel automatically recalculates formulas that use Functions when the values of a cell have changed.

**Create a Formula using a Function**

1. Select the cell that will contain the result of the formula.
2. Type an equal sign and then type the function name (In the example below, the function name is "sum").
3. Type an open parenthesis and then type the arguments of the function (the cell references or values).
4. Press the Enter key.

**The Most Common Excel Functions**

1. **Min (find the minimum value in a list)**
   To find the minimum value in a list, click on the cell below the list and click on the arrow to the right of the AutoSum icon \(\sum\). Select Min. Click on the AutoSum icon \(\sum\) again, the cell will reflect the minimum.
2. **Max (find the maximum value in a list)**
   To find the maximum value in a list, click on the cell below the list and click on the arrow to the right of the AutoSum icon \( \Sigma \). Select Max. Click on the AutoSum icon \( \Sigma \) again, the cell will reflect the maximum.

3. **Average (find the average of values in a list)**
   To find the average value in a list, click on the cell below the list and click on the arrow to the right of the AutoSum icon \( \Sigma \). Select Average. Click on the AutoSum icon \( \Sigma \) again, the cell will reflect the average.

### Less Common Excel Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Defined</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>The sum of the values. This is the default function for numeric data.</td>
</tr>
<tr>
<td>Count</td>
<td>The number of data values. The Count summary function works the same as the COUNTA worksheet function. Count is the default function for data other than numbers.</td>
</tr>
<tr>
<td>Average</td>
<td>The average of the values.</td>
</tr>
<tr>
<td>Max</td>
<td>The largest value.</td>
</tr>
<tr>
<td>Min</td>
<td>The smallest value.</td>
</tr>
<tr>
<td>Product</td>
<td>The product of the values.</td>
</tr>
<tr>
<td>Count Nums</td>
<td>The number of data values that are numbers. The Count Nums summary function works the same as the COUNT worksheet function.</td>
</tr>
<tr>
<td>StDev</td>
<td>An estimate of the standard deviation of a population, where the sample is a subset of the entire population.</td>
</tr>
<tr>
<td>StDevp</td>
<td>The standard deviation of a population, where the population is all of the data to be summarized.</td>
</tr>
<tr>
<td>Var</td>
<td>An estimate of the variance of a population, where the sample is a subset of the entire population.</td>
</tr>
<tr>
<td>Varp</td>
<td>The variance of a population, where the population is all of the data to be summarized.</td>
</tr>
</tbody>
</table>

*To see all Excel 2007 Functions open the excel application, click on help 📚 and type functions in the search box.*
Adding Numeric Values Using the AutoSum Command

This is a command in MS Excel that will automatically sum values.

1. To find the sum value of the numbers in a list, click on the cell below the list and click on the arrow to the right of the AutoSum icon \( \sum \). Select Sum from the drop down menu.

   Or

2. Double-click the AutoSum icon. \( \sum \) The value will appear in the cell.

   **Note**: The AutoSum function works in a specific way. AutoSum adds values above the Active Cell. If there are no values above the Active Cell, AutoSum adds from left to right.

AutoCalculate

The AutoCalculate box is designed to show the user simple formulas. That is, without the manual calculation.

Perform a calculation using the AutoCalculate box

1. Select the cells containing the values to be calculated.
2. Towards the lower right corner of the screen, the result of the calculation (the Average, the Count and the Sum) will appear in the AutoCalculate box.
3. To see several calculation choices available in the AutoCalculate box, right-click in the box. The following menu will appear. Make any selection. Your new choice will appear in the AutoCalculate box, along with the Average, Count and Sum.

<table>
<thead>
<tr>
<th>Customize Status Bar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell Mode: Ready</td>
</tr>
<tr>
<td>Signatures: Off</td>
</tr>
<tr>
<td>Information Management Policy: Off</td>
</tr>
<tr>
<td>Permissions: Off</td>
</tr>
<tr>
<td>Caps Lock: Off</td>
</tr>
<tr>
<td>Num Lock: On</td>
</tr>
<tr>
<td>Scroll Lock: Off</td>
</tr>
<tr>
<td>Fixed Decimal: Off</td>
</tr>
<tr>
<td>QuietType Mode: Off</td>
</tr>
<tr>
<td>End Mode: Not Recording</td>
</tr>
<tr>
<td>Macro Recording: Not Recording</td>
</tr>
<tr>
<td>Selection Mode:</td>
</tr>
<tr>
<td>Page Number:</td>
</tr>
<tr>
<td>Average: 1716.5</td>
</tr>
<tr>
<td>Count: 4</td>
</tr>
<tr>
<td>Numerical Count:</td>
</tr>
<tr>
<td>Minimum:</td>
</tr>
<tr>
<td>Maximum:</td>
</tr>
<tr>
<td>Sum: 6874</td>
</tr>
<tr>
<td>View Shortcuts:</td>
</tr>
<tr>
<td>Zoom: 100%</td>
</tr>
<tr>
<td>Zoom Slider:</td>
</tr>
</tbody>
</table>
Section III

Learning Objectives

- Goal Seeking
- The Scenario Manager: Forecasting the Outcome of a Worksheet
- Protecting Cells and Objects
- Creating Named Ranges for use in a formula.
- Creating Relative and Absolute references in a formula.
- The Paste Function Command
- Defining, Creating and Applying Macros to a spreadsheet.
Goal Seeking

When goal seeking, Microsoft Excel varies the value in a cell you specify until a formula that's dependent on that cell returns the result you want. Use the Goal Seek command when you want to find a specific value for a particular cell by adjusting the value of only one other cell.

A psychology student has a class grade of 72.75. She has asked the Professor to calculate what they would need to receive on the final exam in the term to get a final grade of 95. Using goal seek would be valuable so that Excel can automatically recalculate all formulas involved.

1. On the Data tab, in the Data Tools group, click on What-If Analysis, and then click Goal Seek.
2. In the Set cell box, enter the reference for the cell that contains the formula you want to resolve. (In this example, this is cell F6.)
3. In the To Value box, type the result you want. (In the example below, this is 95.)
4. In the By Changing Cell box, enter the reference for the cell that contains the value you want to adjust. (In this example, this is cell E6) Or Click in the cell on your document sheet to select it.
5. Click Ok to continue. The grade she needs is now visible in the document sheet. She will need a score of 184 to get a final grade of 95.
The Scenario Manager

A scenario is a set of values you use to forecast the outcome of a worksheet. You can create and save different groups of values on a worksheet and then switch to any of these new scenarios to view different results. For example, if you want to create a budget but are uncertain of your revenue, you can define different values for the revenue and then switch between the scenarios to perform what-if analyses.

Consider the following scenario where you want to calculate a budget analysis change:

<table>
<thead>
<tr>
<th></th>
<th>Gross</th>
<th>$70,000</th>
</tr>
</thead>
<tbody>
<tr>
<td>19</td>
<td>Cost</td>
<td>$25,000</td>
</tr>
<tr>
<td>20</td>
<td>Gross Profit</td>
<td>$45,000</td>
</tr>
</tbody>
</table>

3. On the Data tab, in the Data Tools group, click What-If Analysis, and then click Scenario Manager.

4. Click Add.

5. In the Scenario name box, type a name for the scenario.

6. In the Changing cells box, enter the references for the cells that you want to change.

To preserve the original values for the changing cells, create a scenario that uses the original cell values before you create scenarios that change the values.
7. Under Protection, select the options that you want.

8. Click **OK**.

9. In the **Scenario Values** dialog box, type the values that you want for the changing cells.

10. To create the scenario, click **OK**.

11. If you want to create additional scenarios, repeat steps 2 through 8. When you finish creating scenarios, click **OK**, and then click **Show/Close** in the **Scenario Manager** dialog box.

12. To create additional scenarios, click **Add**, and then repeat steps.

13. To see a comparison of all the scenarios created, click **Summary** in the **Scenario Manager** dialog box.

14. Select **Scenario Summary** and click **OK**.
Protecting Cells and Objects

You can lock cells to prevent others from changing the data within them. Locking cells has no effect unless the sheet is protected. By default, a worksheet is locked. To view this setting, click on **Format** under the **Home** tab. Click on **Format Cells**, and then click on the **Protection** tab.

### Protecting a Sheet

1. Under the **Home** tab, in the **Cells** section, click on the **Format** icon and select **Protect Sheet**.
2. The Protect Sheet dialog box will appear. Select your preferences. You may add a password for added security. Click Ok.

   Or

3. Under the Review tab, in the Changes section, click on Protect Sheet.

If you add a password to protect the sheet users will only be able to remove protection from the worksheet only if they know the password. If you attempt to alter the sheet you will get the following message.

Removing Protection from a Sheet

1. Click on Format
2. Select Unprotect Sheet
3. Enter the password if you had set one. Click OK. The sheet is now unprotected.

   Or

4. Under the Review tab, in the Changes section, click on Unprotect Sheet.
Protecting Specific Cells

1. If the worksheet is protected, under the Review tab, in the Changes group, select Unprotect Sheet.
2. If prompted, type the password to unprotect the worksheet.
3. Select the entire worksheet by pressing Ctrl+A, or by clicking the Select All button.

4. On the Home tab, in the Font group, click the Format Cell Font dialog box launcher.

5. On the Protection tab, clear the Locked check box, and then click OK.

6. In the worksheet, select only the cells that you want to lock.
7. On the Home tab, in the Font group, click the Format Cell Font dialog box launcher again.
8. On the Protection tab, select the Locked check box, and then click OK.
10. You can chose to type a password for the worksheet to prevent other users from making protection decisions on the sheet.

11. Click **OK**. You are now able to edit every cell except those you have locked.

**Named Ranges in a Formula**

A Range Name is a name that you give to refer to a range of cells. A range is a group of cells next to each other on a sheet. It is easier to type the “name” of the cells in a formula than typing the cell references. For example "sales_pants" is easier to remember than BC230:BG450.

**Guidelines**

1. The first character of a name must be a letter or an underscore character. Remaining characters in the name can be letters, numbers, periods, and underscore characters.
2. Names cannot be the same as a cell reference, such as E$120 or L2N2.
3. Underscore characters and periods may be used as word separators. For example, Profit_Loss or First.Quarter.
4. A name can contain up to 255 characters.
5. Names can contain uppercase and lowercase letters. Microsoft Excel does not distinguish between uppercase and lowercase characters in names. For example, if you have created the name *Codes* and then you create another name called *CODES* in the same workbook, the second name will replace the first one.

**Naming a Range**

1. **Select** the range of cells

<table>
<thead>
<tr>
<th>Yearly Sales Projections by Department</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Leo</strong></td>
</tr>
<tr>
<td>2001</td>
</tr>
<tr>
<td>2002</td>
</tr>
<tr>
<td>2003</td>
</tr>
<tr>
<td>2004</td>
</tr>
<tr>
<td>2005</td>
</tr>
</tbody>
</table>

2. Under the **Formula** tab, in the **Defined Names** group, click on **Define Name**.
3. The **New Name** dialog box will appear. If there is a heading in your selection, it will be entered by default. To change this, type a name.

4. Under **Scope** select Workbook or a worksheet. The range will be automatically entered in the **Refers To** field.

5. Click **OK** when finished.

**Applying Named Ranges in a Formula**

1. **Select a cell** that will hold the result of the formula.
2. **Type** the named range in place of where you would type cell references and press the **Enter** key. See Below.
Edit/Delete Named Ranges in a Workbook

1. Under the Formulas tab, under the Defined Names group, click on the Name Manager.
2. As shown below, click on the name you wish to edit or delete. Once it is selected click on Edit or Delete.

![Image of Name Manager]

3. When finished click Close.

The Paste Function Command

The Paste Function tool guides a user through the process of creating functions as well as defining each argument within a function.

Inserting a Function

1. Select the cell where the function is to be entered.

2. Click the Insert Function icon or click the Insert menu and then select Function.
3. Select the function to be used from the Function Category list. (The categories segment the larger number of functions into smaller lists. If not sure, select "All").

**Defining, Creating, and Applying Macros to a Spreadsheet**

If you perform a task repeatedly in Microsoft Excel, you can automate the task with a macro. A macro is a series of commands and functions that are stored in a Visual Basic module that you can run whenever you need to perform the task. You record a macro just as you record music with a tape recorder. You then run the macro to repeat, or "play back," the commands.

**Adding the Developer Tab**

For these tasks you will be using the Developer tab. If you don’t see the Developer tab on your Excel Ribbon follow the steps below to add it.

1. Click the Microsoft Office Button , and then click Excel Options.
2. Click Popular, and then select the Show Developer tab in the Ribbon check box.
3. The Developer tab is now visible in the Ribbon.
4. Click on the Developer tab.
5. Set the security level temporarily to enable all macros, by clicking on **Macro Security** under the **Code** group.

6. Under **Macro Settings**, click **Enable all macros** and then click **Ok**. It is recommended that you return to the settings that disable all macros after you finish working with macros as potentially harmful code can run.

**Creating a Macro**

1. On the **Developer** tab under the **Code** group click on **Visual Basic**.

2. Under the **Insert** tab click **Module**.

3. In the code window of the module, type or copy the macro code that you want to use.

4. To run the macro from the module window, press **F5**.

5. On the **File** menu, click **Close and Return to Microsoft Excel** when you finish writing the macro.
# Excel Specifications & Limits

## Workbook and Worksheet Specifications and Limits

- **Workbook and Worksheet Specifications and Limits**
  - Calculations Specifications and Limits
  - Charting Specifications and Limits
  - Pivot Table and Pivot Chart Reports Specifications & Limits
  - Shared Workbook Specifications and Limits

## Worksheet and Workbook Specifications and Limits

<table>
<thead>
<tr>
<th>Feature</th>
<th>Maximum limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open workbooks</td>
<td>Limited by available memory and system resources</td>
</tr>
<tr>
<td>Worksheet size</td>
<td>1,048,576 rows by 16,384 columns</td>
</tr>
<tr>
<td>Column width</td>
<td>255 characters</td>
</tr>
<tr>
<td>Row height</td>
<td>409 points</td>
</tr>
<tr>
<td>Page breaks</td>
<td>1,026 horizontal and vertical</td>
</tr>
<tr>
<td>Total number of characters that a cell can contain</td>
<td>32,767 characters</td>
</tr>
<tr>
<td>Characters in a header or footer</td>
<td>255</td>
</tr>
<tr>
<td>Sheets in a workbook</td>
<td>Limited by available memory (default is 3 sheets)</td>
</tr>
<tr>
<td>Colors in a workbook</td>
<td>16 million colors (32 bit with full access to 24 bit color spectrum)</td>
</tr>
<tr>
<td>Named views in a workbook</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Unique cell formats/cell styles</td>
<td>64,000</td>
</tr>
<tr>
<td>Fill styles</td>
<td>32</td>
</tr>
<tr>
<td>Line weight and styles</td>
<td>16</td>
</tr>
<tr>
<td>Unique font types</td>
<td>1,024 global fonts available for use; 512 per workbook</td>
</tr>
<tr>
<td>Number formats in a workbook</td>
<td>Between 200 and 250, depending on the language version of Excel that you have installed</td>
</tr>
<tr>
<td>Names in a workbook</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Windows in a workbook</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Panes in a window</td>
<td>4</td>
</tr>
<tr>
<td>Linked sheets</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td><strong>Scenarios</strong></td>
<td></td>
</tr>
<tr>
<td>Changing cells in a scenario</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Adjustable cells in Solver</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Custom functions</td>
<td>200</td>
</tr>
<tr>
<td>Zoom range</td>
<td>10 percent to 400 percent</td>
</tr>
<tr>
<td>Reports</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Sort references</td>
<td>64 in a single sort; unlimited when using sequential sorts</td>
</tr>
</tbody>
</table>
### Undo levels
- 100

### Fields in a data form
- 32

### Workbook parameters
- 255 parameters per workbook

### Filter drop-down lists
- 10,000

---

### Calculations Specifications and Limits

<table>
<thead>
<tr>
<th>Feature</th>
<th>Maximum limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number precision</td>
<td>15 digits</td>
</tr>
<tr>
<td>Smallest allowed negative number</td>
<td>-2.2251E-308</td>
</tr>
<tr>
<td>Smallest allowed positive number</td>
<td>2.2251E-308</td>
</tr>
<tr>
<td>Largest allowed positive number</td>
<td>9.99999999999999E+307</td>
</tr>
<tr>
<td>Largest allowed negative number</td>
<td>-9.99999999999999E+307</td>
</tr>
<tr>
<td>Largest allowed positive number via formula</td>
<td>1.7976931348623158e+308</td>
</tr>
<tr>
<td>Largest allowed negative number via formula</td>
<td>-1.7976931348623158e+308</td>
</tr>
<tr>
<td>Length of formula contents</td>
<td>8,192 characters</td>
</tr>
<tr>
<td>Internal length of formula</td>
<td>16,384 bytes</td>
</tr>
<tr>
<td>Iterations</td>
<td>32,767</td>
</tr>
<tr>
<td>Worksheet arrays</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Selected ranges</td>
<td>2,048</td>
</tr>
<tr>
<td>Arguments in a function</td>
<td>255</td>
</tr>
<tr>
<td>Nested levels of functions</td>
<td>64</td>
</tr>
<tr>
<td>User defined function categories</td>
<td>255</td>
</tr>
<tr>
<td>Number of available worksheet functions</td>
<td>341</td>
</tr>
<tr>
<td>Size of the operand stack</td>
<td>1,024</td>
</tr>
<tr>
<td>Cross-worksheet dependency</td>
<td>64,000 worksheets that can refer to other sheets</td>
</tr>
<tr>
<td>Cross-worksheet array formula dependency</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Area dependency</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Area dependency per worksheet</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Dependency on a single cell</td>
<td>4 billion formulas that can depend on a single cell</td>
</tr>
<tr>
<td>Linked cell content length from closed workbooks</td>
<td>32,767</td>
</tr>
<tr>
<td>Earliest date allowed for calculation</td>
<td>January 1, 1900 (January 1, 1904, if 1904 date system is used)</td>
</tr>
<tr>
<td>Latest date allowed for calculation</td>
<td>December 31, 9999</td>
</tr>
<tr>
<td>Largest amount of time that can be entered</td>
<td>9999:59:59</td>
</tr>
</tbody>
</table>
Charting Specifications and Limits

<table>
<thead>
<tr>
<th>Feature</th>
<th>Maximum limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Charts linked to a worksheet</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Worksheets referred to by a chart</td>
<td>255</td>
</tr>
<tr>
<td>Data series in one chart</td>
<td>255</td>
</tr>
<tr>
<td>Data points in a data series for 2-D charts</td>
<td>32,000</td>
</tr>
<tr>
<td>Data points in a data series for 3-D charts</td>
<td>4,000</td>
</tr>
<tr>
<td>Data points for all data series in one chart</td>
<td>256,000</td>
</tr>
</tbody>
</table>

PivotTable and PivotChart Report Specifications and Limits

<table>
<thead>
<tr>
<th>Feature</th>
<th>Maximum limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>PivotTable reports on a sheet</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Unique items per field</td>
<td>1,048,576</td>
</tr>
<tr>
<td>Row or column fields in a PivotTable report</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Report filters in a PivotTable report</td>
<td>256 (may be limited by available memory)</td>
</tr>
<tr>
<td>Value fields in a PivotTable report</td>
<td>256</td>
</tr>
<tr>
<td>Calculated item formulas in a PivotTable report</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Report filters in a PivotChart report</td>
<td>256 (may be limited by available memory)</td>
</tr>
<tr>
<td>Value fields in a PivotChart report</td>
<td>256</td>
</tr>
<tr>
<td>Calculated item formulas in a PivotChart report</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Length of the MDX name for a PivotTable item</td>
<td>32,767</td>
</tr>
<tr>
<td>Length for a relational PivotTable string</td>
<td>32,767</td>
</tr>
</tbody>
</table>

Shared Workbook Specifications and Limits

<table>
<thead>
<tr>
<th>Feature</th>
<th>Maximum limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Users who can open and share a shared workbook at the same time</td>
<td>256</td>
</tr>
<tr>
<td>Personal views in a shared workbook</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Days that change history is maintained</td>
<td>32,767 (default is 30 days)</td>
</tr>
<tr>
<td>Workbooks that can be merged at one time</td>
<td>Limited by available memory</td>
</tr>
<tr>
<td>Cells that can be highlighted in a shared workbook</td>
<td>32,767</td>
</tr>
<tr>
<td>Colors used to identify changes made by different users when change highlighting is turned on</td>
<td>32 (each user is identified by a separate color; changes made by the current user are highlighted with navy blue)</td>
</tr>
<tr>
<td>Excel tables in a shared workbook</td>
<td>0 (zero)</td>
</tr>
</tbody>
</table>
NOTE  A workbook that contains one or more Excel tables cannot be shared.